COM Surrogate et la visionneuse d’images Windows 7

COM Surrogate et la visionneuse d’images Windows 7

COM Surrogate et la visionneuse d’images Windows 7

39 commentaires sur COM Surrogate et la visionneuse d’images Windows 7

Suite à un souci avec le processus COM Surrogate apparu sous Windows 7 lors de l’ouverture de la visionneuse d’images, je me suis mis en quête de rechercher plusieurs solutions. Ce problème me semble être apparu après les diverses MàJ de Firefox, mais n’étant pas dans l’esprit d’isoler élément après élément, j’ai plutôt recherché une rustine afin de palier à ce « plantage ».

Après diverses recherches m’ayant quasiment toutes conduites sur la piste d’un problème de codec vidéo, j’ai enfin trouvé la solution me permettant de remédier au message d’erreur « COM Surrogate a cessé de fonctionner » chaque fois que j’ouvrais la visionneuse et qui m’empêchait même de fermer celle-ci, que ce soit avec la croix, le raccourci « Alt+F4 » ou encore le gestionnaire de tâches Windows:

Ouvrez « Panneau de Configuration », puis « Système et sécurité », « Système », et enfin « Paramètres système avancés ».

Dans « Performances », cliquez sur « Paramètres… », puis allez dans l’onglet « Prévention de l’exécution de données »

Sélectionnez  « Activer la prévention d’exécution des données pour tous les programmes et les services, sauf ceux que je sélectionne : » puis cliquez sur « Ajouter… ». Sélectionnez enfin « dllhost ».

Si un message d’avertissement apparaît, cliquez sur « OK ».

Apparaît alors COM Surrogate dans la fenêtre. Cliquez sur « Appliquer », puis redémarrez le PC.

Cette solution a fonctionné pour moi, j’espère qu’il en sera de même pour vous si vous rencontrez le même genre de problème.

VN:F [1.9.22_1171]
Notez la pertinence de cet article !
Rating: 3.8/5 (27 votes cast)
COM Surrogate et la visionneuse d'images Windows 7, 3.8 out of 5 based on 27 ratings

About the author:

39 commentaires

  1. ANDRE  - 27 juillet 2010 - 18 h 03 min

    Ne fonctionne pas avec windows seven x64

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    • The Alien  - 27 juillet 2010 - 18 h 10 min

      Qu’est ce que ça te donne exactement ?

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
      • lucena_fr  - 28 juillet 2010 - 19 h 52 min

        Sous mon windows 7 (64 bits), lorsque j’active la procédure prévention d’exécution de données et que je veux y ajouter le fichier dllhost, j’ai le message « Vous ne pouvez pas activer les attributs de l’exécution de données sur l’exécutable 64 bits »
        Il s’agirait donc d’un bug de windows 7 version 64 bits

        VA:F [1.9.22_1171]
        Rating: 4.9/5 (7 votes cast)
  2. The Alien  - 28 juillet 2010 - 20 h 08 min

    Je suis sous Win 7 x86 sur mes deux pc, je viens de faire les MàJ de Firefox vers la 3.6.8 et de thunderbird vers la 3.1.1 … et même plantage sur le deuxieme pc, ce serait donc l’un de ses deux élements qui aurait perturbé le processus. Quelles sont de votre coté, les dernières mises à jour que vous avez fait ?

    VN:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
  3. lucena_fr  - 28 juillet 2010 - 21 h 11 min

    j’ai les mêmes versions, mais il me semble que j’avais déjà le problème avant les mises à jour. Je ne vois pas par ailleurs en quoi ces applications perturberaient une application media.

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    • The Alien  - 28 juillet 2010 - 21 h 16 min

      car la mise à jour de Firefox contient un correctif touchant l’affichage des images, donc media … je vais tenter de downgrader mon firefox pour voir si le problème vient de là.

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
  4. The Alien  - 28 juillet 2010 - 21 h 45 min

    Bon, après avoir réinstaller firefox 3.6.7 sur l’un de mes pc (malheureusement une version anglaise) et réactiver la prévention par défaut dans Windows, je n’ai plus ce souci.
    Je vais tâcher de trouver une version française de firefox 3.6.7 en attendant pour ceux que ça intéresse, et faire part de ce problème à Mozilla.

    VN:F [1.9.22_1171]
    Rating: 2.0/5 (1 vote cast)
  5. lucena_fr  - 28 juillet 2010 - 22 h 21 min

    Votre version Windows 7 est la 32 ou 64 bits?

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    • The Alien  - 28 juillet 2010 - 22 h 23 min

      Pour ma part, mes deux pc sont restés en 32bitis (appelé aussi x86)

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
    • The Alien  - 28 juillet 2010 - 23 h 04 min

      Voilà, vous pourrez trouver la procédure sur le lien au dessus.

      VN:F [1.9.22_1171]
      Rating: 3.0/5 (1 vote cast)
  6. lucena_fr  - 29 juillet 2010 - 5 h 58 min

    Le problème est que la procédure préventio d’execution de données ne fonctionne pas avec windows 7 64 bits quand on veut y ajourter le fichier dllhost

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
  7. lucena_fr  - 29 juillet 2010 - 17 h 25 min

    Merci!
    Tout est nickel

    Cordialement

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
  8. Tchoun  - 18 août 2011 - 1 h 23 min

    Merci de l’astuce ! Bonne continuation

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
  9. Joelle030  - 3 mars 2012 - 12 h 18 min

    Bonjour
    J’ai suivi à la lettre et je ne peux pas modifier . J’ai un message : pas avec 64 bits !
    Help !!!!
    Merci

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    • The Alien  - 3 mars 2012 - 20 h 11 min

      Bonsoir,
      Quel est le windows? Anti virus? version de firefox?

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
  10. Joelle030  - 3 mars 2012 - 23 h 57 min

    Bonjour
    J’ai Windows 7 pro . Avira free et firefox 10.0.2 .
    Merci d’avoir répondu .

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    • The Alien  - 9 mars 2012 - 14 h 23 min

      Avez vous un autre programme type Nero ?

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
  11. Joelle030  - 9 mars 2012 - 14 h 26 min

    Néro , non , je n’ai pas de logiciel particulier pour graver .
    Merci

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    • The Alien  - 13 mars 2012 - 2 h 08 min

      Alors essayez de reprendre la même manipulation, mais au lieu de choisir le dossier System32, sélectionnez le dossier Syswow64, puis le fichier dllhost.
      En espérant que ce sera utile

      VN:F [1.9.22_1171]
      Rating: 5.0/5 (3 votes cast)
  12. Joelle030  - 14 mars 2012 - 10 h 40 min

    Merci pour cette réponse .
    J’ai depuis mis à jour  » galerie de photos windows life  » qui a résolu tous mes problèmes de lecture . Mes images s’ouvrent très vite et je peux même lire les fichiers RAW .
    La mise à jour Windows m’indiquait qu’il n’y avait pas de  » mise à jour disponible  » . J’ai tenté celle ci non proposée et ça marche très bien . Merci beaucoup .

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
  13. MH  - 21 mars 2012 - 17 h 13 min

    Bonjour,
    Je suis arrivé ici en cherchant un moyen de régler le problème « COM surrogate »
    Comme Joelle030, j’ai le même message « vous ne pouvez pas activer les attributs de prévention de l’exécution des données sur les exécutables 64 bits ».
    J’ai Windows 7 édition familiale premium, en anti-virus, j’ai Avira antivir Personal, puis enfin, firefox 11.0 (même si j’écris actuellement sur google chrome). Et je n’ai pas trouvé de programme « Nero » sur mon PC.

    Le problème est que je n’ai pas réussi à trouver « Syswow64 ». Je ne sais pas pourquoi.
    Merci d’avance.

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
  14. MH  - 21 mars 2012 - 17 h 18 min

    Non, je viens de comprendre. Pour trouver Syswow64, il fallait revenir en arrière, vu que le fichier se trouver en dessous du fichier system32, et non dedans. Par contre, lorsque je veux sélectionner dllhost, il me dit que ça m’expose aux virus. Je ne suis pas sûr que ce soit recommandable. Y a-t-il un autre moyen de régler ce problème ?

    VA:F [1.9.22_1171]
    Rating: 3.0/5 (1 vote cast)
    • The Alien  - 21 mars 2012 - 18 h 05 min

      Bonjour, avez vous essayé la solution proposée par joelle030 en utilisant le fichier placé en lien ?!

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
  15. MH  - 21 mars 2012 - 20 h 17 min

    Si vous parlez de Galerie de photos Windows Live 2011, je l’avais téléchargé. Le problème restait le même, mais je viens de remarquer à l’instant que si j’utilise Galerie de photo Windows Live, il n’y a plus de problème à faire défiler les séries d’images. C’est le fait de faire défiler les images avec « Visionneuse de photo Windows » qui me causait des problèmes. On peut dire maintenant que mon problème est réglé (merci d’avoir répondu) même si je ne saisis toujours pas le problème avec la Visionneuse, qui ne faisait pas ça auparavant.

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
  16. ANDY  - 15 juillet 2012 - 13 h 22 min

    CELA A FONCTIONNE A MERVEILLE AVEC VISTA 32B.
    JE VOUS REMERCIE BEAUCOUP POUR VOTRE METHODOLOGIE…

    TOUT EST RENTRE DANS L ORDRE…

    AU PLAISIR………..
    Andy.

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
  17. Joëlle030  - 15 juillet 2012 - 14 h 24 min

    Bonjour Andy
    Il serait bon que vous nous donniez la méthode qui a été efficace dans l’intérêt de tous ceux qui viennent sur ce forum .

    Merci

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
  18. ANDY  - 15 juillet 2012 - 15 h 58 min

    EFFECTIVEMENT… JE N AVAIS PAS PRECISE DE CE DONT JE PARLAIS..
    DONC.. A CHAQUE FOIS QUE JE VOULAIS VISIONNER UN FILM.. OU METTRE VLC MEDIA PLAYER EN ACTION… APPAIRAISSAIT UNE PETITE RECTANGLE EN PLEIN MILIEU DE MON ECRAN…. OU ETAIT ECRIT…
    COM Surrogate ……
    J AI EU BEAU FAIRE.. DE FACONS DIFFERENTES.. JUSQU A CE QUE JE TROUVE VOTRE FORUM AVEC L EXEMPLE EN HAUT DE CETTE PAGE… C EST A DIRE DE SUIVRE A LA LETTRE CE QUI EST ECRIT DANS LES EXEMPLES EN TABLEAU CONCERNANT…. COM Surrogate et la visionneuse d’images Windows 7…

    J AI DONC SUIVI A LA LETTRE… CHAQUE TABLEAU…. CHAQUE MOT…. ET DEPUIS TOUT EST REDEVENU NORMAL… MON ORDI FONCTIONNE A MERVEILLE COMME SI RIEN NE S ETAIT JAMAIS PASSE.

    MERCI A TOUS…
    JE SOUHAITE QUE MON EXEMPLE VOUS SERVE ET VOUS INCITE A LE REPRODUIRE..
    AU PLAISIR DE VOUS LIRE…. MERCI ENCORE…
    MEILLEURES SALUTATIONS……..
    Andy.

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
  19. Laurent  - 22 juillet 2012 - 20 h 14 min

    Bonjour,

    J’ai un HP I7 4 Processeurs 8 cœurs 64 bits (windows familly) et le même problème, dès que je fais défiler les photos un peux vite.
    Je reçois le même message : COM Surrogate à cessé de fonctionné !

    J’ai suivis tous vos conseils… Rien n’y fait le message est toujours là malgré vos différentes manips.

    Ne serais-ce pas un problème qui ce crée car nos machines sont trop rapide pour ce programme ?
    Je n’ai jamais rencontré ce problème en 32bits même sur HP.
    Si vous avez une solution je suis preneur.

    Mes meilleurs salutations à tous

    VA:F [1.9.22_1171]
    Rating: 3.0/5 (2 votes cast)
    • The Alien  - 26 juillet 2012 - 19 h 51 min

      Je doute que ce soit un problème de puissance… Ce service est utilisé par divers programmes, notamment ceux de gravure, une verification complete de l’ensemble des mises à jour disponiblent pour l’intégralité des softs installés pourrait éventuellement corriger le problème

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
  20. Catherine  - 26 juillet 2012 - 16 h 18 min

    Même problème que Laurent… je viens d’acheter un ordi assez puissant pour utiliser photoshop, première, etc. confortablement, (genre, gros fichier, raw, etc.) et à cause de Surrogate etc. je ne peux même pas faire défiler les photos sur la « visionneuse photos de windows »… ça énerve!!! (et quand j’essaie la solution proposée plus haut, j’ai le message 64bits etc.)
    Help!!! avez-vous la solution???

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    • The Alien  - 26 juillet 2012 - 19 h 44 min

      Dans un cas comme celui là, je vous invite déjà à vérifier les mises à jour des drivers de vos cartes graphiques

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
  21. Laurent  - 26 juillet 2012 - 22 h 58 min

    Bonsoir,

    J’ai cherché à résoudre ce problème par différente techniques… nada , je pense que nos ordinateurs son trop rapide
    pour le programme en question ou c’est un bug sur les 64 bits.

    Pour ma par j’utilise photofiltre pour éditer les photos, il est gratuit.

    Si vous avez un HP comme moi, vous avez un outils intégré pour les photos, les films, etc.. le cas échéant il vous permets
    de les visionner. Si je trouve une solution je ne manquerait pas de vous en faire parte.
    Il y a aussi picaza
    Mes meilleures salutations à tous
    Laurent

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
    • The Alien  - 26 juillet 2012 - 23 h 42 min

      Sous les différents 64bits que j’ai pu tester avec différentes configurations, je n’ai pas rencontré le problème… Je reste persuadé que c’est une erreur logiciel et non matériel / logiciel… Je tâcherai de me pencher sur le problème dans les prochains jours, mais difficile lorsque l’erreur n’est pas présente sur la machine… Peut être serait il intéressant que l’un de vous me laisse accès via teamviewer, au moins pour dans un premier temps, une phase d’observation des programmes présents au démarrage… Si l’un de vous maîtrise aussi le msconfig, il serait intéressant de faire un démarrage sélectif et ne lancer que les composants windows, sans pour autant passer par un mode sans échec

      VN:F [1.9.22_1171]
      Rating: 0.0/5 (0 votes cast)
  22. LIGET  - 27 février 2013 - 15 h 21 min

    Bonjour
    j’avais le même souci que ci dessous
    lucena_fr
    28 juillet 2010 at 19 h 52 min | Permalink | Reply

    Sous mon windows 7 (64 bits), lorsque j’active la procédure prévention d’exécution de données et que je veux y ajouter le fichier dllhost, j’ai le message « Vous ne pouvez pas activer les attributs de l’exécution de données sur l’exécutable 64 bits »
    Il s’agirait donc d’un bug de windows 7 version 64 bits

    toutefois je me suis aperçu que dans le gestionnaire du registre lorsque je l’actionnai an vue d’arrêter le processus il y vait bien le fichier dlhost… En le selectionnant et par un clic droit  » ouvrir le dossier y attenant » il apparait que ce fichier se trouve également dans le dossier SysWOV34 de windows 7 . j’ai donc appliqué la procédure appliquée dans ce post . Com surrogate est apparue dans la fenêtre des préventions….j’ai donc cliqué sur appliquez et redemarrer le PC . Maintenant je vais voir si cela fonctionne, car c’est récent.
    Si vous pouviez m’indiquer si cela a ou non fonctionné; Merci
    bien cordialement

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)
  23. mickael  - 13 février 2014 - 17 h 04 min

    Bonjour,

    J’ai eu aussi un problème avec ce processus , mais pas de blocage de la visionneuse windows .

    Le problème était une énooorme consommation de la RAM .

    J’ai suivi votre procédure et sa a fonctionné parfaitement sur un seven x64 .

    Merci bien .

    VA:F [1.9.22_1171]
    Rating: 0.0/5 (0 votes cast)

Laisser un commentaire

Notifiez-moi des commentaires à venir via email. Vous pouvez aussi vous abonner sans commenter.

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

Back to Top